Sujet sur Discussion utilisateur:Reptilien.19831209BE1

Aller à la navigation Aller à la recherche

Un peu d'aide sur un modèle avec 2 paramètres, stp ?

4
Hsarrazin (discussioncontributions)

Salut Reptilien,

Je m'adresse à toi car je sais que tu touches pas mal ta bille en modèles, même quand ça n'est pas du lua

Je suis en train d'essayer de construire un modèle permettant l'affichage de livres bilingues en 2 colonnes, comme ici (et page suivante).

La position de la colonne fr alterne entre droite et gauche pos=d ou pos=g, et la langue de l'autre colonne peut être variée, mais par défaut "la" (vu que c'est quand même là qu'on a le max de livres bilingues)...

J'ai construit 2 modèles Modèle:EntêteBilingue et Modèle:PiedBilingue qui fonctionnent quand le français est à gauche, et l'autre langue le latin...

J'ai déjà intégré le paramètre lg=(code de langue) pour pouvoir varier la langue ; et je cherche à ajouter le paramètre pos=g/d pour alterner la mise en page, suivant ces données.

J'ai fait des essais de syntaxe, ici, mais ça ne fonctionne pas... je présume que ça vient du switch, mais je n'arrive pas à corriger la syntaxe....

Quand tu auras un moment, peux-tu m'aider, stp ?

PS : @SyB~Anicium voudrait, en plus, pouvoir faire varier la largeur des colonnes ; je me dis qu'on pourrait sans doute le faire avec 1 paramètre larg, l'autre colonne étant de largeur 100-larg. Ou bien est-ce trop compliqué pour du simple css ?

Hsarrazin (discussioncontributions)

OK... je crois que j'ai résolu mon problème... il fallait utiliser {{!}} pour insérer les | dans le switch \o/

accessoirement, j'ai trouvé comment superposer le français et l'autre langue, que j'ai mis avec paramètre |h ou par défaut...

Reptilien.19831209BE1 (discussioncontributions)

Et bien visiblement tu n'as point besoin de moi :-) Je ne vois pas ce que je peux dire d'autre.

Hsarrazin (discussioncontributions)

oui, je suis plutôt fière de moi sur ce coup-là... c'est un de mes premiers modèles complexes "toute seule" !!

je me suis galérée un bon bout de temps, avant de piger qu'il fallait mettre le modèle pour les pipes... en gros, ça a occupé plusieurs heures de mon insomnie

Répondre à « Un peu d'aide sur un modèle avec 2 paramètres, stp ? »